What's new

LIST OF CURRENT KNOWN BUGS

Anxiety

Member
Many have requested it, here it is.
A list of every currently known bug as well as their solution (if applicable.)
Up to date as of 18-03-2020.

I tried to sort them in a way that makes sense, and ordered so that the more crucial things are near the top. Ctrl+F is your friend.
If anyone has any solutions that aren’t listed, or if I’ve missed any known bugs, please feel free to post them.
If you've experienced a bug that isn't known, follow the guideline found HERE to file a bug report.
(And if you file a report and I miss it, feel free to PM me so I can add it to this list)

I'll do my best to keep this list up to date, as well as provide any relevant quotes/comments from the staff team regarding each issue.

Disclaimer: Just because a bug has been acknowledged doesn't mean its actively being worked on, nor is it necessarily a top priority. This is an old game that we are all running on new hardware. There are a LOT of bugs, and a very small team working on a very large number of issues. Be patient, be positive, and if you have feedback/suggestions/complaints, please try to express them in a positive manner. :)

P.S. Acknowledged = Staff have made a comment on said bug.
Post automatically merged:

USABILITY BUGS:

Instant game crash on startup:
STATUS: Acknowledged
SUMMARY: Some players are completely unable to launch the game. They might not even make it to the splash screen.
Solution: Subjective. Please visit this thread for further assistance: https://community.projecttorque.racing/threads/unable-to-open-game.205/

Unable to connect to server when trying to log in:
STATUS: Acknowledged
SUMMARY: As soon as the player logs in, they get a window pop up saying “Please check connection.”
SOLUTION: It seems to be an issue with Steam. Many players report that launching the game in administrator mode solves the problem, albeit that isn’t the recommended solution.
Alternatively, players have reported success by taking the ENTIRE Project Torque game folder (generally found in C:\Program Files (x86)\Steam\steamapps\common\Project Torque) and simply moving it to a completely different folder, such as downloads or the desktop.

Sometimes the game window refuses to re-open or crashes after tabbing out:
STATUS: Acknowledged
SOLUTION: Spam click on the PT icon in the taskbar and keep pressing enter until the game decides to open. Usually it happens quickly. Unless your game crashes. Unfortunately there's no known fix as of yet.

Excessive lag and/or random disconnect back to login screen:
STATUS: Acknowledged
SUMMARY: Some players are reporting very excessive lag which causes all their opponents cars to jump around. It might be really difficult to drive non-ghost races for these players. And these same players might be able to play other online games perfectly fine without significant lag.
SOLUTION: Unknown. Developers are aware of the issue. I’d encourage you to try playing through the lowest latency VPN you are able to use, and report back the results.

Some users are unable to map gamepad/wheel controls.
STATUS: Acknowledged
SOLUTION:
Open Steam and right click on Project Torque, go to Properties.
On the General tab, make sure "Steam Input" is set to forced off.
Close and start Project Torque.
Go to Settings and Controls. Then in the 2nd tab, map your controller.
Don't overwrite the keyboard controls.
Alternatively, many users report simply launching the game in administrator mode to also solve the problem. But this is not recommended.

Analogue inputs unable to utilize 100% of the axis:
STATUS: Acknowledged
SUMMARY: When using analogue inputs (for example, if you use a steering wheel with pedals,) players are only able to get 99% of the maximum input.
SOLUTION: Unknown.
This is due to Windows reporting 99%. In the direct input stuff, there is a range from 0 to 256.
Most controllers are only going up to 255 though for some reason.


Getting stuck in race lobbies:
STATUS: Reported
SUMMARY: Some players report that they simply get stuck into a room when they join. The game tells them that they joined as spectator, even when the check box is not checked. When the race ends, the player is unable to exit the room or do anything besides Alt+F4
SOLUTION: Unknown.

Disappearing mouse cursor:
STATUS: Acknowledged
SUMMARY: The mouse cursor disappears at random.
SOLUTION: Press the key to open your trunk (default I) and generally the problem goes away. If you still have trouble with the cursor, make sure your windows version is fully up to date.

Unable to change keyboard input language on login screen:
STATUS: Reported
SUMMARY: Some players who use foreign character keyboards by default are unable to switch their input language to english in order to log in to their account.
SOLUTION: Set the default windows language to english. Yes, this will change the entire operating system, but currently its the only known solution.

Steering responsiveness bug:
STATUS: Reported
SUMMARY: Some players are reporting the steering responsiveness is not being applied correctly. For example, on analogue inputs there should be zero steering smoothing. But some players aren’t getting 1:1 response with their inputs. Ie. when a wheel user turns their wheel quickly, the game takes a moment to “catch up” with the car’s wheels.
Alternatively, there are keyboard players who are reporting having “instant steering” where they try to turn and instantly go full lock, rather than having the wheels smoothly steer to position like they should.
SOLUTION: Some players report that using an xbox controller emulator (such as x360ce) solves the problem with gamepads or wheels. Keyboard solution is currently unknown.
 
Last edited:

Anxiety

Member
GRAPHICAL BUGS:

16:9 users are unable to select 1366x768.

Status: Acknowledged
Solution: Unknown. Some players suggest using a third party program such as Fullscreenizer Link to force the game into “fullscreen” while using the windowed option at this resolution.
Fullscreenizer Link


Post-Effects graphics bug:
STATUS: Reported
SUMMARY: Some players report that when they enable Post-Effects in the game’s graphics settings, the game looks way overexposed when they try to play using camera F1.
SOLUTION: Unknown. Use a different camera for now or disable post-effects.

Blue shadows graphics bug:
STATUS: Acknowledged
SUMMARY: When running Direct X 9 on Intel integrated GPUs, some players are experiencing the shadow textures to incorrectly load as solid blue blobs.
SOLUTION: Revert the game to Direct X version 8 for a guaranteed solution. Please try updating graphics, Direct X, and .NET framework drivers if you are experiencing this issue.

Player name tags above the car are off-centered:
STATUS: Reported
SUMMARY: After joining a crew, the player name tags will appear shifted off to the side.
SOLUTION: Unknown

Rear-view mirror appears black:
STATUS: Reported
SUMMARY: Some players report that on some tracks, specifically Nurgenhoch, Kanagawa, and mud summer mist environments. the rear-view mirror loads as a black box.
Black MIRROR happens to me on these tracks, for now...
Project Torque Screenshot 2020.03.18 - 14.38.26.67.pngProject Torque Screenshot 2020.03.18 - 14.38.53.79.png
On MUD looks like it happens on all tracks with that daytime (Summper mist)!
Project Torque Screenshot 2020.01.06 - 13.24.31.38.pngProject Torque Screenshot 2020.03.18 - 14.45.27.47.png
SOLUTION:
Me and Teydi have discovered that turning off the post process effects fixes the issue


Missing track textures:
STATUS: Acknowledged
SUMMARY: Some tracks are loading with missing textures that appear like checkered flags.
SOLUTION: Unknown

Missing walls/objects:
STATUS: Acknowledged
SUMMARY: Some players report, usually after long game sessions, that tracks will start loading without the textures of walls or other objects. You can still run into said objects, but they are invisible.
SOLUTION: Restart the game and it should go back to normal.

Corall tail light bug:
STATUS: Reported
SUMMARY: Some players report on night time tracks the Corall’s tail lights are turned off. On daytime tracks the lights are turned on. Which is opposite from what it should be of course.
SOLUTION: Unknown


Hexan GT graphical bugs:
STATUS: Reported
SUMMARY: The Hexan GT muffler looks out of place, and doesn’t even reach the cutouts in any of the bumpers. Some players also report that the Hexan GT cockpit textures aren’t loading in some environments ie. San Francisco night.
SOLUTION: Unknown.

Hexan Drift front wheels:
STATUS: Reported
SUMMARY: After the first round of a drag race, some players report that the front wheels of the hexan drift car appear to be moved forward by several inches. (before and after photo in quote below)


Tracks in the voting screen appearing as solid white boxes:
STATUS: Acknowledged
SOLUTION: Unknown.
This is due to a duplication in the server side config. Users need to report what maps this happens to, ideally track also.
Voting to join a track with an all white preview will result in issues with the lobby, most of the time kicking users out.
Y'all heard the man! Make sure to screenshot and report when this happens to you!

Vote screen "thumb-up" icons appearing all wonky:
STATUS: Reported
SOLUTION: Unknown
when you vote for a map and the little thumbs up thingy shows up sometimes they aren't all lined up properly, like some have a bigger font or are placed awkwardly, doesn't seem to be mode or track dependent and doesn't really influence the gameplay


Emoticons not showing up in the game chat list:
STATUS: Reported
SUMMARY: Nobody is able to view the list of emoticons when they click the little smiley at the bottom left of the chat box.
SOLUTION: Unknown.
 
Last edited:

Jack

Administrator
Staff member
Analogue inputs unable to utilize 100% of the axis:
This is due to Windows reporting 99%. In the direct input stuff, there is a range from 0 to 256.
Most controllers are only going up to 255 though for some reason.

Tracks in the voting screen appearing as solid white boxes:
This is due to a duplication in the server side config. Users need to report what maps this happens to, ideally track also.
Voting to join a track with an all white preview will result in issues with the lobby, most of the time kicking users out.

Some cars/items require an amount of XP to unlock which doesn’t correspond with any level ups.
Upgrades are set by XP rather than level. So if an upgrade is set to XP 5000 and that is between level 3 and 4 then the upgrade is at level 3.5.
Working to show XP and level rather than just level to resolve this. Ideally all items unlock at level rather than XP.

No track rulers in any mode:
Currently disabled in game working on removing it for now.
 
Last edited:

Anxiety

Member
GENERAL GAME BUGS:

Red item mystery boxes are not giving rewards:

STATUS: Acknowledged
SOLUTION: Unknown

Red item mystery boxes sometimes spawn outside of the map:
STATUS: Reported
SOLUTION: Unknown

Upgrade/styling preset bug:
STATUS: Reported
SUMMARY: Sometimes when players load into a lobby or switches a preset, the upgrades/styling aren't correctly applied.
SOLUTION: Switch through the performance preset options to get the upgrades back. Some players report having to go back to the garage and manually re-add the upgrades. The issue seems to be far more common with cars that are newly bought.

Arcade physics in Sim and vice versa:
STATUS: Reported
SUMMARY: Sometimes players get stuck with arcade physics in Simulation mode directly after playing with arcade physics. The same can happen in the opposite way from Sim-Arcade.
SOLUTION: Restart the game. And usually the problem goes away. But some players report needing to delete the “options” file under \Project Torque\save\game.

Race lobby bug:
STATUS: Reported
SUMMARY: Sometimes in the race lobby, either one of the active room members might not appear to load in, or sometimes incorrect name tags are displayed above someone’s car.
SOLUTION: N/A.

Spectator mode stats bug:
STATUS: Reported
SUMMARY: Joining spectator mode is causing players to lose rating and reliability even though they don’t actually race. It also counts as a loss on their profile.
SOLUTION: Unknown

Accel balance bug:
STATUS: Reported
SUMMARY: Some players are reporting that with some cars, the accel A+ balancer actually reduces the car’s 0-60 time.
SOLUTION: N/A. The acceleration balancer isn’t a literal acceleration increase, but a shortening of gear ratios. I’d imagine on some cars (especially more powerful ones, shorter gear ratios mean more wheel spin which means a longer 0-60 time from standstill.) Its likely not a bug. But perhaps worthy of a discussion on potentially renaming “accel” to “gearing” or “gear-ratio.” :)

Bodykit parts glitch:
STATUS: Reported
SUMMARY: Sometimes when installing bodykit parts such as bumpers, they might disappear. And you might see a Hungarian placeholder logo in place of the previous bumper item.
SOLUTION: The bug only appears on the client’s side. But changing to a different bumper or restarting the game reverts it back to normal.

Lost clean sector bonus:
STATUS: Reported
SUMMARY: Players report randomly losing the clean sector bonus when they race, even though they are driving perfectly clean.
SOLUTION: N/A. Presumably this issue happens because collisions are detected by the server rather than the client. When you see cars jumping around, that’s exactly what the server sees too. You might not collide with anything on your screen, but the server sees that you did. Unfortunately this is likely due to out-dated netcode, and there is no solution.

Champagne shaking:
STATUS: Reported
SUMMARY: When players get the bonus champagne shaking after a race, they are often unable to pop the cork and obtain the bonus RP.
SOLUTION: The champagne bonus seems to only work if you play in windowed mode, or at lower resolutions.

Online friends:
STATUS: Reported
SUMMARY: Some players report that the servers are showing that they have many more friends online than the real amount.
SOLUTION: Unknown

No track rulers:
STATUS: Acknowledged
SUMMARY: The game has a nifty “track ruler” feature where crews can compete to temporarily “own” certain tracks by earning the most RP on them within a time frame. Right now the feature is not working at all.
SOLUTION: Unknown
Currently disabled in game working on removing it for now.


Some cars/items require an amount of XP to unlock which doesn’t correspond with any level ups.
STATUS: Acknowledged
SOLUTION: N/A. Staff are working on a fix.
Upgrades are set by XP rather than level. So if an upgrade is set to XP 5000 and that is between level 3 and 4 then the upgrade is at level 3.5.
Working to show XP and level rather than just level to resolve this. Ideally all items unlock at level rather than XP.


Many objects are not loading in-game:
STATUS: Reported
SUMMARY: When low world detail is selected, certain objects on certain maps aren’t loaded into the game. Not only do the textures not load, nor do the physical objects. Ie. you drive right through the poles on the San Francisco maps.
SOLUTION: Raise the world detail.

Tokyo glitchy camera:
STATUS: Reported
SUMMARY: Sometimes in the beginning of any race on tokyo, the camera is really wonky and clips back and forth through the map.
SOLUTION: Unknown

Kanagawa invisible object:
STATUS: Reported
SUMMARY: When you try to take the shortcut on Kanagawa tracks, there is an invisible object.
SOLUTION: N/A

----------------------

MODE SPECIFIC:

VS:

Sprint race scoring bug:

STATUS: Reported
SUMMARY: In VS mode, when you race in a room with voting enabled, and the track switches from one with laps to a "sprint" course, ONLY the final round of the sprint is taken into consideration for the scoring.

TA:
TA race start bug:

STATUS: Acknowledged
SUMMARY: TA mode sometimes has really wacky race starts. There can be a huge gap between “groups” of players, sometimes spawning players inside of eachother, etc. Some players also report that they are being spawned further and further back behind the field the longer they have the game running.
SOLUTION: Restart the game to fix the spawn distance bug. But the wacky starts in general have no known solution.
Aware of it, hoping to grab the fix soon from Invictus


Spectator starting out of fuel bug:
STATUS: Reported
SUMMARY: If you run out of gas in Thunder Alley and leave the race, and then proceed to join a new race as a drop in spectator, there is a chance you will spawn without any fuel.
SOLUTION: Unknown

TA Trans issue:
STATUS: Reported
SUMMARY: Some players report randomly loading into a TA race and the game seems to not engage the transmission. The player is able to shift, but unable to move, as if they are holding in the clutch.
SOLUTION: Press escape a couple times. (Yes you’re going to have a late start. For now, this is the best known solution.)

Pro Car soft vinyl #6 missing sponsor decals on right side:
STATUS: Reported
SOLUTION: N/A

DRAG:
Buggy race start:

STATUS: Reported
SUMMARY: In the start of drag races, often players will be spawned on top of each other, causing at least one red light penalty, and often one or more players will stay stuck on the start line until someone else finishes.
SOLUTION: Unknown. But at least when the bug occurs and you’re stuck, pressing escape -> rescue allows you to finish the round.

CTF:
Flag steal bonus bug:

STATUS: Reported
SUMMARY: Sometimes when a player steals the flag in CTF, they are awarded a massive instant boost in points.
SOLUTION: N/A. It is unknown as to whether this is a bug or a feature that we don’t yet fully understand.

EXPLORER:
Items bug:
STATUS: Reported
SUMMARY: Sometimes when loading into explorer, no items load in for a player even though other players in the room may be driving around fine and able to collect. Alternatively, sometimes the player loads in and all of the items are there but invisible.
SOLUTION: Unknown

DRIFT:
Score calculation bug:
STATUS: Reported
SUMMARY: If a player "submits" their score within the final few seconds of a round, the score might not be fully calculated. ie. the results screen will show said player's score, but they will not receive any sector master bonus and they might not receive the race win that they earned.
SOLUTION: Unknown
 
Last edited:

Anxiety

Member
FIXED BUGS:

As bugs get squashed, I will add them to this post.
Obviously, many have been fixed already. But I'm only going to report the fixes that are made as of the date this post was created.

Peace and love <3
 

Facepalm

Active member
I have three things to type

Having driven the Corall more than any other car I own at this point, I can say I haven't had the light bug happen to me.

For the glitchy Drag camera, that's something that happens on VS too.
Specifically have seen it happen on a Tokyo track, both day and night

For the black mirror glitch, people have reported Kanagawa also has that. Personally haven't had the blacked out mirrors happen to me.
 

Anxiety

Member
Having driven the Corall more than any other car I own at this point, I can say I haven't had the light bug happen to me.
If I remember correctly, it was @TEYDI who first spotted the bug. perhaps it has something to do with specific graphics settings, or perhaps its been fixed. Any updates, Teydi?

For the glitchy Drag camera, that's something that happens on VS too.
Specifically have seen it happen on a Tokyo track, both day and night
I think you may be right. It must be an issue with tokyo highway specifically rather than drag mode itself. Has anybody experienced this bug on other maps?
Anyways I moved it to general gameplay bugs.
 

TEYDI

Active member
If I remember correctly, it was @TEYDI who first spotted the bug. perhaps it has something to do with specific graphics settings, or perhaps its been fixed. Any updates, Teydi?

Project Torque Screenshot 2020.03.18 - 14.33.59.72.pngProject Torque Screenshot 2020.03.18 - 14.31.36.85.pngProject Torque Screenshot 2020.03.18 - 14.30.43.33.pngProject Torque Screenshot 2020.03.18 - 14.36.47.39.png
Post automatically merged:

I have three things to type

Having driven the Corall more than any other car I own at this point, I can say I haven't had the light bug happen to me.

For the glitchy Drag camera, that's something that happens on VS too.
Specifically have seen it happen on a Tokyo track, both day and night

For the black mirror glitch, people have reported Kanagawa also has that. Personally haven't had the blacked out mirrors happen to me.

Black MIRROR happens to me on these tracks, for now...

Project Torque Screenshot 2020.03.18 - 14.38.53.79.pngProject Torque Screenshot 2020.03.18 - 14.38.26.67.png

On MUD looks like it happens on all tracks with that daytime (Summper mist)!

Project Torque Screenshot 2020.03.18 - 14.45.27.47.png Project Torque Screenshot 2020.01.06 - 13.24.31.38.pngProject Torque Screenshot 2020.03.18 - 14.45.36.79.png
 
Last edited:

Facepalm

Active member
It's a pretty weird bug, cause it doesn't happen on my end.
I have all settings maxed out, running 19:6 at 1920x1080.
I do have post processing off though. Not sure if that helps?
 

TEYDI

Active member
It's a pretty weird bug, cause it doesn't happen on my end.
I have all settings maxed out, running 19:6 at 1920x1080.
I do have post processing off though. Not sure if that helps?
you Sir were right. Turning off the POST EFFECTS solved the black mirror BUG!

Project Torque Screenshot 2020.03.18 - 20.12.27.69.pngProject Torque Screenshot 2020.03.18 - 20.12.03.67.pngProject Torque Screenshot 2020.03.18 - 20.11.37.68.png
 

Facepalm

Active member
Not sure where this should be reported, but you should note down the invisible Kanagawa prop on the shortcut
 

NOS Waster

New member
Not sure where this should be reported, but you should note down the invisible Kanagawa prop on the shortcut
Each NEW bug should have its own topic made. Please use the search function to see if it has already been reported.

Anxiety currently checks the forum for new reports every day, so he will add it to the post after the topic made.
 

Anxiety

Member
Not sure where this should be reported, but you should note down the invisible Kanagawa prop on the shortcut

Updated list to include the invisible kanagawa object.

edit: that was my bad, as it had been reported already and I forgot to add it to the list. We gucci.
 
Top